#1  
Old 09-29-2010, 12:59 PM
Peasant
 
Join Date: Sep 2010
Location: georgia
Posts: 31
Default Crust issues

I am moving this post to this section...more suitable topic for here.

Newbie here...using my indoor 30" electric oven to cook pizzas on a stone at 500F (I think). My oven is a Wolf and it has a "Bake Stone" mode. The owners manual specifically talks about using this mode for pizza cooking, so I guess that's the right mode to be using (and I have used that mode)

I'm getting an edible result, but would like to have a browner, crispier crust in the center of the pie. The edges and the center ingredients are cooking nicely, browning fine...but that bottom needs help.

Ingredients were a high protein flour, an instant yeast, a decent EVO, San Marzano tomatoes. Dough was mixed in KitchenAid mixer, gave it about an hour or two to rise.

My last pie was prepared using EVO, then sauce, then cheese, etc,. I'm wondering of the EVO is preventing the crust from "crisping"?

I'm really inexperienced...so no question or suggestion is too basic.

Thanks folks!
Reply With Quote
  #2  
Old 09-29-2010, 05:44 PM
Journeyman
 
Join Date: Jun 2009
Location: minnesota, usa
Posts: 472
Default Re: Crust issues

Photos would be helpful!
I assume you ARE using a baking stone?
Are you letting it heat up for a good long time--like an hour?
Can you tell what exactly "bake stone" mode does vs. regular bake?
Gas or electric?
Without further info, I would say your stone isn't hot enough and/or you're putting too much stuff on top.
Reply With Quote
  #3  
Old 09-29-2010, 06:59 PM
Peasant
 
Join Date: Sep 2010
Location: georgia
Posts: 31
Default Re: Crust issues

Photo's...not possible.

Baking stone....Yes

Heating for a long time....well yes. However, I lost my argument with Wifey over temp- she thought 450. So thats where things started. I turned it up after first pie, but doubt that the stone had time to really take advantage of higher temp. (Gee, this kinda sounds like the answer here, donnit?)

Bake mode...not sure and owners manual doesn't explicitly say. Oven is a high end model (Wolf) and I think it probably has to do with which elements are on...but not sure.

Gas or electric....electric.

I suspect solution is higher temp...pie was pretty lightly dressed.
Reply With Quote
  #4  
Old 09-29-2010, 07:08 PM
Journeyman
 
Join Date: Jul 2007
Location: Los Angeles, CA
Posts: 308
Default Re: Crust issues

Definitely you must try pre-heating at full temp (500 or 550 deg F) for longer time... like 1 hr.

Also you need to consider where in the oven the stone is located. Different ovens perform differently and finding the best place for the stone takes experimentation. My old Chambers liked the stone on the lowest rack setting. The piece-of-junk oven I'm using now likes it in the middle.

Also, "recovery time" of a stone is something to be mindful of when baking multiple pies one after another.
Reply With Quote
  #5  
Old 09-29-2010, 09:12 PM
Journeyman
 
Join Date: Jun 2009
Location: minnesota, usa
Posts: 472
Default Re: Crust issues

Yes, I think most here would advocate the hotter the better for oven temp (as WFO pizza cooks, we think anything less than about 750F is too cold) but your dough recipe would be a factor here as well.
If your pies are cooking on the top faster than the bottom, that tells me your oven air temp is too hot in comparison to your stone. As I said, I like to give them an hour or more preheat depending on what oven temp I am shooting for. An IR thermometer like we use for WFO cooking might be worth your while to get an idea of where you're at with the stone temp. About $30 for a cheapie at the tool store or ebay and lots of fun for other stuff, too.
Is there an upper heating element that comes on during pizza bake mode? That could be part of the problem.
Reply With Quote
  #6  
Old 09-30-2010, 03:06 AM
Peasant
 
Join Date: Sep 2010
Location: georgia
Posts: 31
Default Re: Crust issues

Quote:
Originally Posted by splatgirl View Post
Is there an upper heating element that comes on during pizza bake mode? That could be part of the problem.
I don't know...will try calling my oven mfg'er to ask this.

Thanks for the help.
Reply With Quote
  #7  
Old 09-30-2010, 03:09 AM
Peasant
 
Join Date: Sep 2010
Location: georgia
Posts: 31
Default Re: Crust issues

Quote:
Originally Posted by BrianShaw View Post
Definitely you must try pre-heating at full temp (500 or 550 deg F) for longer time... like 1 hr.
I did pre-heat..but as I say, it was preheating to 450. We cooked one pie (which brought the temp down) and then tried resetting the oven to 500. But I know we didnt give things time to readjust. I suspect that this may have been the problem.

Thanks Brian.
Reply With Quote
  #8  
Old 09-30-2010, 07:01 AM
70chevelle's Avatar
Apprentice
 
Join Date: Apr 2008
Location: PA
Posts: 125
Default Re: Crust issues

Your dough recipe and crust thickness has a lot to do with how your pizza comes out also. Can you give your dough recipe, specifically the hydration % and oil % and if your pizza's are thick or thin crusts.
Reply With Quote
  #9  
Old 09-30-2010, 07:13 AM
Peasant
 
Join Date: Sep 2010
Location: georgia
Posts: 31
Default Re: Crust issues

Quote:
Originally Posted by 70chevelle View Post
Your dough recipe and crust thickness has a lot to do with how your pizza comes out also. Can you give your dough recipe, specifically the hydration % and oil % and if your pizza's are thick or thin crusts.
I really don't have a recipe, per se...I used the recipe on the back of the flour bag (I know, how lame).

Just acquired Peter Rheinhart's book (American Pie) and plan to follow one of his recipes.

Talked to my oven manufacturer (Wolf). They were not particularly helpful in deciphering what burners operate in what mode. I'm going to try Bake Convection next time and will crank this thing all the way (550- I think).

Thanks for your help, chevelle.
Reply With Quote
  #10  
Old 09-30-2010, 07:26 AM
Journeyman
 
Join Date: Jul 2007
Location: Los Angeles, CA
Posts: 308
Default Re: Crust issues

On stone in a regular oven, try Reinharts NeoNepolitan dough first.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
The secret to WFO crispy crust? Ken524 Pizza 31 06-28-2010 06:45 AM
Is it wrong to pre-bake the crust? sslandry Pizza 3 05-30-2009 11:16 AM
What does yeast do in pizza crust????????? edschmidt Get Cooking 11 05-18-2009 06:38 PM
Whole grain crust texture james Hearth Bread and Flatbread 20 03-01-2009 05:45 PM
Original Matzoh Crust Pizza. pizza master Pizza 1 01-14-2007 08:52 AM


All times are GMT -7. The time now is 05:12 AM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
2006/10 Forno Bravo, LLC