web analytics
Not firing up to temp :( - Forno Bravo Forum: The Wood-Fired Oven Community

Announcement

Collapse

Forum Issues Update

We are continuing to work diligently to resolve the issues currently being experienced with the PhotoPlog. Thank you for your patience!
See more
See less

Not firing up to temp :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not firing up to temp :(

    Hey guys I've finally managed to finish my oven. I cured it for about a week before adding the dome insulation etc and after adding a few inches of high grade bloody expensive ceramic fibre blanket and rendering the dome I decided to fire it up.

    I built a fairly decent sized fire in the centre of the oven which I pushed to the side after about an hour and a half probaby using about 5 or so big (ish) logs in the process but after all that my wall temp was about 350c and my floor temp was a rather poor 180c at best . I do have a sufficent 4" of perlite insulation under the floor and I'm using nice thick storage heater bricks for the floor (which I researched and should be fine!)

    Where am I going wrong here? Should I try it with a monster fire? Or just feed it for longer? Check out my pics.

    Cheers guys!
    Attached Files

  • #2
    Re: Not firing up to temp

    Sounds to me like your oven still needs to be purged of moisture. Although you might get the crown of the dome up to a decent temp the base of the dome and the floor are much more difficult to dry out. There is usually a ring of black soot around the bottom which indicates the temp at the bottom is a lot lower. Don't rush it. Try to keep a gentle fire going for longer and you will find the oven performance just keeps on improving. The moisture in the floor seems to be about the hardest to remove in my experience because of the tendency of heat to rise.
    Kindled with zeal and fired with passion.

    Comment


    • #3
      Re: Not firing up to temp

      OK,
      It's pretty likely that there's a lot of moisture under the floor! I'll continue to build small fires all this week before trying to fire it up again properly at the weekend. Thank you for your help, I'll let you know how it goes!

      Comment


      • #4
        Re: Not firing up to temp

        I agree. IME, it took several good loooong firings for my oven to dry out and start holding heat like it should. The hearth and insulation ends up sucking a lot of water during a build and being completely covered like it is, takes a long time to evaporate it all out.

        Comment


        • #5
          Re: Not firing up to temp

          Ace. I'm relieved that this may be a normal side effect of a new build , so much hard work has gone into it so I'm hoping it'll pay off!

          Also does anyone know the recommended size of fire?? Can you see the fire in my pic, is this about right or should it be a little bit bigger?

          Comment


          • #6
            Re: Not firing up to temp

            p.s. Does my build look 'about right' by the way!? In all honesty the first oven I've seen was the one I built! I have an album uploaded on my profile with loads of progress pics!

            Comment


            • #7
              Re: Not firing up to temp

              It looks better than all right! Fantastic work! And as long as you've got insulation in all the right places you can quit worrying.
              As far as the size of the fire, I think the rule of thumb around here is "as big as you can make it", but you might want to ease into that. Better to go lower and slower and build up to infernal when an oven is new and still damp.

              Comment


              • #8
                Re: Not firing up to temp

                What is your door height to oven height ratio ?

                It should be about 63%. Judging by the photos, your door height appears too high.

                Comment


                • #9
                  Re: Not firing up to temp

                  If I remember correctly it is about 65% The internal height of the dome is about 15" and the door height is 10". I remember reading about the ratios and being careful to get it all right so hopefully I didn't cock that one up!

                  Comment


                  • #10
                    Re: Not firing up to temp

                    You're right though it does look quite high! I think it looks that way because the oven floor starts quite a bit above the brick surround. I'm going to check that when I get home though!

                    Cheers for the feedback

                    Comment


                    • #11
                      Re: Not firing up to temp

                      Result!!

                      Fired oven last night with the biggest fire I've done so far, after about an hour floor temp was about 350c walls were about 450c, I let it burn down for another 45mins. Cooked a few pizzas which were lovely although I think I let the fire burn down too much before sweeping the coals to the side!

                      My outside wall temp was cold to touch after 2 hours so that's a bloody good result! My expensive ceramic fibre insulation was worth the investment .

                      Cheers all for the help, I'll post up some pics once I've given the whole thing a nice finish!

                      Comment

                      Working...
                      X